Power in Flux
Likes Likes:  0
Page 2 of 4 FirstFirst 1234 LastLast
Results 11 to 20 of 40

Thread: AC-23 Motor not spinning with Curtis 1238 controller

              
   
   
  1. #11
    Member
    Join Date
    Dec 2015
    Location
    Philadelphia, PA, US
    Posts
    41
    Post Thanks / Like
    Quote Originally Posted by frodus View Post
    Those controllers are particular about the order in which you turn on and off certain inputs, for safety reasons.

    From what I recall, Interlock should be completely closed before turning on KSI. If interlock opens, you must cycle KSI.

    Glad you got it working.
    Thans Frodos and Huges. I was worried the motor might be a bust as it was on the motorcycle when i welded few tacks

    Pictures attached. Still have a long way to go to get it road worthy. Pulley ratio is 5:1. If the motor gets too hot on drive then i can swap out the drive pulley for a 28 teeth brining the ratio down to 6.5:1

    Now i need to figure out the BMS connections. Thats something i am a little scared off as it can mess with the batteries



    IMG_20170228_203237.jpgIMG_20170302_215321.jpgIMG_20170327_215122.jpgIMG_20170405_212841.jpgIMG_20170405_212856.jpg

    I'll also make a video on the connections for people like me who are new to all these electronics and post it on youtube.
    Last edited by milton; 11 April 2017 at 1419.

  2. #12
    Seņor Member podolefsky's Avatar
    Join Date
    Oct 2010
    Location
    Boulder, CO
    Posts
    3,890
    Post Thanks / Like
    Code 28 is motor temp hot cutback. That sounds more like a bad connection to the temp sensor.

    Glad you got it working. Yes, you either need interlock connected to controller 12V or set it to type 2 (interlock turns on with KSI). Make sure it's controller 12V (pin 25) and not your system 12V (they need to be isolated).

    You can turn interlock and KSI on/off in any sequence.

    There's a setting called high pedal disable (HPD) that checks throttle <25% before interlock is enabled, or it throws code 47 and cuts power. It might be enabled for golf car programming, but I'm pretty sure it's turned off for their standard auto/motorcycle program. Either way, if throttle is 0 when you turn on it won't fault.
    - Noah Podolefsky -
    The GSX-E

  3. #13
    Seņor Member podolefsky's Avatar
    Join Date
    Oct 2010
    Location
    Boulder, CO
    Posts
    3,890
    Post Thanks / Like
    By the way, bike is looking awesome!
    - Noah Podolefsky -
    The GSX-E

  4. #14
    Senior Member Hugues's Avatar
    Join Date
    Jan 2012
    Location
    Switzerland
    Posts
    1,080
    Post Thanks / Like
    Pretty cool build !
    we have pretty much the same gear,
    can't you reach a ratio of 7:1 with this rear sprocket ? i have 7.04 with 176 tooth on wheel and 25 on motor

    watch out when you connect your BMS, you can also damage the electronic of the BMS if you invert your wires. First you need to connect all your wires to your battery, then you check manually with a voltmeter that you got them in the right order on the BMS connector, then you can plugin the connector in the BMS. They also sell a tool to check this, but it can be done manually.
    Regards from Switzerland
    My 2.5 Upgrade Thread

  5. #15
    Junior Member Nando's Avatar
    Join Date
    Nov 2015
    Location
    San Francisco
    Posts
    23
    Post Thanks / Like
    Milton, that is a very impressive build. Looks like you built the frame and the front suspension, wow. Building the whole bike from scratch, hope it goes smooth.
    Current R1200RT, previously FZ1, HawkGT, Nighthawk 650, XS650. Loved every single one of them, now it's time for an electric bike!

  6. #16
    Senior Member
    Join Date
    Aug 2011
    Location
    Eastern Massachuesetts
    Posts
    166
    Post Thanks / Like
    I like it!
    It reminds me a little of Graucho's bike.
    rightview.jpg
    "obstacles suck but challenges are fun"

  7. #17
    Senior Member Stevo's Avatar
    Join Date
    Nov 2014
    Location
    Behind the Redwood Curtain- REDWOOD ORIGINAL!!
    Posts
    338
    Post Thanks / Like
    Cool. What color ya gonna paint it? Mural?
    Original build: http://vorworxemc.wix.com/vorworx
    Current rides: '96 Honda Ohlins VFR, '03 Cannondale C440R, '03 Cannondale Cannibal, '06 Yamaha 450 Wolverine 4x4

  8. #18
    Member
    Join Date
    Dec 2015
    Location
    Philadelphia, PA, US
    Posts
    41
    Post Thanks / Like
    Quote Originally Posted by podolefsky View Post
    By the way, bike is looking awesome!
    Thanks podolefsky

  9. #19
    Member
    Join Date
    Dec 2015
    Location
    Philadelphia, PA, US
    Posts
    41
    Post Thanks / Like
    Quote Originally Posted by Hugues View Post
    Pretty cool build !
    we have pretty much the same gear,
    can't you reach a ratio of 7:1 with this rear sprocket ? i have 7.04 with 176 tooth on wheel and 25 on motor

    watch out when you connect your BMS, you can also damage the electronic of the BMS if you invert your wires. First you need to connect all your wires to your battery, then you check manually with a voltmeter that you got them in the right order on the BMS connector, then you can plugin the connector in the BMS. They also sell a tool to check this, but it can be done manually.
    I am keeping that ratio as an option. My pulley is from Gates and they have quite some options for drive side pulley. If needed I can replace the drive side with a smaller one.

  10. #20
    Member
    Join Date
    Dec 2015
    Location
    Philadelphia, PA, US
    Posts
    41
    Post Thanks / Like
    Quote Originally Posted by Nando View Post
    Milton, that is a very impressive build. Looks like you built the frame and the front suspension, wow. Building the whole bike from scratch, hope it goes smooth.
    Yes Nando. I built every thing from scratch including the front suspension and rear swing arm. Also trying to figure out the design for the handle bar since the entire bike is curve, would concentrate on some big bends rather then small bends.

    Right now there is one hurdle. The rear pulley is a tad wobbly. One of the bolt hole is not centered. Will have to figure out a way to do that.

Page 2 of 4 FirstFirst 1234 LastLast

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •