Power in Flux
Likes Likes:  1
Page 2 of 2 FirstFirst 12
Results 11 to 13 of 13

Thread: Problem with Hub Motor Kelly Controller (brushless)

              
   
   
  1. #11
    Member scoot440's Avatar
    Join Date
    Dec 2011
    Location
    Lubbock, Texas
    Posts
    55
    Post Thanks / Like
    Checking in to see if anyone has had any luck or made any progress. I have tried Nuts and Volts' workaround, but have had no success at 12,18, 24, 0r 48V. Any new suggestions?

  2. #12
    Junior Member
    Join Date
    Aug 2018
    Posts
    1
    Post Thanks / Like
    Working on wiring my electric boat using a Kelly PM48 permanent magnet controller. I am having the same problem. The controller powers up fine, then when throttled up, the prop gives a little twitch (in the correct direction in both forward and reverse) then stops and throws an error code. At first I interpreted it as 1-3,low-voltage, but that can't be right. All of the accessories are powered off of the same battery bank, and there isn't room for another one.

    I will be incredibly dissapointed if the controller won't work in this configuration.

    Has there been any progress towards solving this problem?

    Does anyone have any recommendations for an isolated dc-dc converter for supplying the controller? My battery bank is 36v, and the low-voltage cutoff for the controller is 19V according to the manual. Frankly, it's bullshit that I have to do this type of work-around to make a controller work out of the box.

  3. #13
    Senior Member Stevo's Avatar
    Join Date
    Nov 2014
    Location
    Behind the Redwood Curtain- REDWOOD ORIGINAL!!
    Posts
    718
    Post Thanks / Like
    WOW! I just noticed how old this thread was from the OP... I would try what they found works first just to see if you can get yours working, then experiment with an isolated DC-DC like a Vicor and post an update if you can make that solution work. Sorry, I have no experience with Kelly.
    Well, actually there was one Kelly.... that was a loooooong time ago though LOL
    Last edited by Stevo; 31 August 2018 at 1001.
    Current rides: '96 Honda Ohlins VFR, '03 Cannondale C440R, '03 Cannondale Cannibal, '06 Yamaha 450 Wolverine 4x4
    Current builds: WORX.VOR.v3.2

Page 2 of 2 FirstFirst 12

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •